четверг, 25 мая 2017 г.

Отключение SMB 1.0 через GPO


Disable SMBv1 Server with Group Policy


This will configure the following new item in the registry


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Registry entry: SMB1 REG_DWORD: 0 = Disabled


To configure this using Group Policy:
Open the Group Policy Management Console. Right-click the Group Policy object (GPO) that should contain the new preference item, and then click Edit.
In the console tree under Computer Configuration, expand the Preferences folder, and then expand the Windows Settings folder.
Right-click the Registry node, point to New, and select Registry Item.



In the New Registry Properties dialog box, select the following:
Action: Create
Hive: HKEY_LOCAL_MACHINE
Key Path: SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
Value name: SMB1
Value type: REG_DWORD
Value data: 0






This disables the SMBv1 Server components. This Group Policy needs to be applied to all necessary workstations, servers, and domain controllers in the domain.

Note: WMI filters can also be set to exclude unsupported operating systems or selected exclusions such as Windows XP.

Caution! Be careful when making these changes on domain controllers where legacy Windows XP or older Linux and 3rd party systems (that do not support SMBv2 or SMBv3) require access to SYSVOL or other file shares where SMB v1 is being disabled.

понедельник, 15 мая 2017 г.

Шифровальщик WannaCry: ссылки для загрузки патчей для Windows

В начавшейся вчера масштабной атаке вируса-шифровальщика WannaCrypt (он же Wana decrypt0r, WannaCry и WCr) используется дыра в сервере SMB (v.1.0) Windows, которую Microsoft залатала еще в марте, но далеко не все пользователи своевременно устанавливают на свои системы регулярно выпускаемые обновления, чем и воспользовались злоумышленники, запустившие распространение WannaCrypt по всему миру.

14 марта этого года Microsoft выпустила специальный бюллетень MS17-010, описывающий проблему и дающий рекомендации по ее устранению. В этом бюллетене также указаны ссылки для загрузки патча, устраняющего эту уязвимость. Прямые ссылки для загрузки:

Windows XP SP3
Windows XP SP2 x64
Windows Server 2003 x86
Windows Server 2003 x64
Windows Vista x86 Service Pack 2
Windows Vista x64 Edition Service Pack 2
Windows 8 32-bit
Windows 8 x64
Windows Server 2008 x86
Windows Server 2008 x64
Windows Server 2008 R2 x64
Windows Server 2008 R2 for Itanium
Windows 7 32-bit Service Pack 1
Windows 7 x64 Service Pack 1
Windows 8.1 32-bit
Windows 8.1 x64
Windows 10 32-bit
Windows 10 x64
Windows 10 Version 1511 32-bit
Windows 10 Version 1511 x64
Windows 10 Version 1607 32-bit
Windows 10 Version 1607 x64

Патч для Windows 10 версии 1703 не нужен - заплатка уже вшита в систему.

понедельник, 10 апреля 2017 г.

Обновление курсов валют в 1с требует авторизацию ИТС.

С очередным обновлением перестали обновляться курсы валют и классификаторы банков - требует авторизоваться в ИТС.

Обходим:
Все функции (если не включено, включаем в настройках) - Константы - Использовать альтернативный сервер для загрузки курсов валют/Использовать альтернативный сервер для загрузки классификатора банков (ставим галочку).

четверг, 2 марта 2017 г.

Перенаправление трафика со своего внешнего адреса на другой внешний адрес в Mikrotik.


Пробрасываем порт на другой внешний порт в Интернете.

OLD_PUBLIC_IP = 1.1.1.1
NEW_PUBLIC_IP = 2.2.2.2

/ip firewall nat add chain=dst-nat dst-address=1.1.1.1 protocol=tcp dst-port=80 \
action=dst-nat to-addresses=2.2.2.2 to-ports=80

/ip firewall nat add chain=src-nat dst-address=2.2.2.2 protocol=tcp dst-port=80 \
action=masquerade 

пятница, 2 сентября 2016 г.

Смена IP адреса и DNS через командную строку

netsh interface ip set address name="Подключение по локальной сети" source=static addr=192.168.0.2 mask=255.255.255.0 gateway=192.168.0.1 gwmetric=1

netsh interface ip set dns name="Подключение по локальной сети" static 192.168.0.1 primary
netsh interface ip add dns name="Подключение по локальной сети" 8.8.8.8